Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2018
    Location
    Moon Township
    Posts
    2

    Question Suddenly no electrical response when key inserted, any ideas?

    Our boat is a 2018 Sea Ray SPX 190. I'm usually on it every weekday, and I always start the boat for a few minutes. Last Monday it started fine. When I came Thursday, there was no "beep" or any sign of life when I inserted the key. Nothing electrical worked, just as if the batter switch was off. (but it was on). I assumed i had left something turned on that drained the battery. I took the battery home and charged it. Brought it back to day, reinstalled it, same thing. No response at all when the key is inserted, as though there was no battery. I checked the owners manual for ideas, but I already made sure battery is charged, battery switch is on, not sure what else to check. Does anyone have any suggestions of what else to try? I'm really hoping to use it this weekend!! Thanks!

  2. #2
    Join Date
    Nov 2012
    Location
    RIYC
    Posts
    138

    Default

    First I have no knowledge of you boat, but here are a few thoughts. Did the battery need charging? If it was "dead", and nothing had been left on to drain it, I'd suspect a short circuit somewhere. If the battery did not need to be charged, I'd suspect an open some place. Check with Sea Ray to determine if there is a circuit breaker or a fuse in the main DC buss. If you have a voltmeter, check the battery switch to determine if it is passing power. If it is, check for voltage at the ignition switch.

    Good luck.
    Brondall
    Pero - Cruisers 2670 Rogue
    Prospect, KY





Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •