Results 1 to 11 of 11
  1. #1
    Join Date
    Oct 2012
    Location
    Louisville Yacht Club
    Posts
    395

    Default Canvas and frame guy

    Hey all I need a canvas and ss tubing guy asap!! Not a fly by night and someone that will come to LYC to assist me with my Monticello bimini!!
    Any thoughts?
    Thanks
    C
    Chris Morris
    Austin-Tatious IV - Monticello River Yacht
    ?- 2013 Malibu 24 MXZ
    T8TrTot - 340 Yachtliner
    Louisville Yacht Club

  2. #2

    Default

    This forum is dead.

    Somebody said there's a FB page that's pretty active, but I dont do FB.

  3. #3
    Join Date
    Oct 2012
    Location
    Louisville Yacht Club
    Posts
    395

    Default

    Quote Originally Posted by Carver36 View Post
    This forum is dead.

    Somebody said there's a FB page that's pretty active, but I dont do FB.
    You aint kidding it is DEAD!!!!
    sad
    Chris Morris
    Austin-Tatious IV - Monticello River Yacht
    ?- 2013 Malibu 24 MXZ
    T8TrTot - 340 Yachtliner
    Louisville Yacht Club



  4. #4
    Join Date
    Nov 2012
    Location
    harrodscreek
    Posts
    25

    Default what happen

    Quote Originally Posted by Cmorris View Post
    You aint kidding it is DEAD!!!!
    sad
    this site used to be busy things not going on are did everyone go else where i know i have not been busy here but have been on the water and seen the boats so who fixed what on there boat this weekend?? i got a new winch strap for my runabout boat trailer so this winter at haul out the old one broke last season



  5. #5
    Join Date
    Nov 2012
    Location
    Springhurst
    Posts
    89

    Default

    I put a new Idle Air Control on one of my houseboat engines (7.4L MPI) because of an erratic alarm and intermittent dying at idle. Hope it solves the problem.

  6. #6

    Default

    I have put three IACs on my 6.2s over the years.

    Found that one for a Ford matches and is cheaper than Mercruiser.



  7. #7
    Join Date
    Nov 2012
    Location
    harrodscreek
    Posts
    25

    Default

    I also this year changed over from points to Elec ingation on my twin crusaders. They sure run alot better now

  8. #8
    Join Date
    Nov 2012
    Location
    Springhurst
    Posts
    89

    Default

    Also solved another weird problem on my 7.4s by back flushing my raw water cooling system. See my long post from several weeks ago.

  9. #9

    Default

    This may be a dumb one to bring up on here, but I have to "back flush" my A/C unit every couple weeks( or at least every month).

    It gets tons of mud out of them and comes out looking like a dark chocolate milk shake.

    I only bring it up because of all the people I've talked to that have never done it. I don't know how they get cool air or keep from throwing their breaker.



  10. #10
    Join Date
    Sep 2017
    Posts
    1

    Default

    Quote Originally Posted by Carver36 View Post
    This may be a dumb one to bring up on here, but I have to "back flush" my A/C unit every couple weeks( or at least every month).

    It gets tons of mud out of them and comes out looking like a dark chocolate milk shake.

    I only bring it up because of all the people I've talked to that have never done it. I don't know how they get cool air or keep from throwing their breaker.
    I am on Ramp "A" at Tartans Landing.
    Get the same issue.
    I think it is where you are in a marina.
    I built in a valve and quick disconnect after the pump where I can blow out the units with shore water quickly.
    Skippy

  11. #11

    Default

    I did the same thing.

    Occasionally I will hook up a portable air compressor. Talk about blowing out mud! LOL



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •